Talemetry Desktop Tools - System Requirements

What are the system requirements for the Talemetry Desktop Tools?


System Requirements

  • Browser
  • IE11 *
  • Chrome
  • Operating System
  • Windows 10 (IE, Chrome)
  • Mac OS X (Chrome)
  • Other System Software
  • * if using Internet Explorer, .NET Framework 4.0 and above is required.  If you do not have this installed, you can download it for free from Microsoft here 

Feedback and Knowledge Base